Comment corriger un dysfonctionnement du composant listbingo (petites annonces) sous joomla

Facebooktwittergoogle_plusmail

Comment corriger un dysfonctionnement du composant listbingo (petites annonces) sous joomla

 

Un dysfonctionnement important que j’ai rencontré lors de mes tentatives d’installation de listbingo sous joomla etait une erreur de type :

Parse error: syntax error, unexpected ‘{‘ in ………./administrator/components/com_feedbingo/feedbingo.php on line 36”

 

Voici une réponse que j’ai trouvé sur le site officiel : http://www.gobingoo.com/resources/faqs/item/5-%E2%80%9Cparse-error-syntax-error-unexpected-in-/administrator/components/com_feedbingo/feedbingophp-on-line-36%E2%80%9D.html

« The above mentioned error on line number 36 of feedbingo.php is due to “try catch exception handling” that might not be supported by your php version you are using.

So please do check your php version. Does it support « try catch exception handling » if not then you have to upgrade your php version to the latest available php version. »

 

Mon hébergeur etant 1and1, j’ai effectué des recherche concernant la version de php utilisée et comment l’uprader. Il semble en effet que la version doive être la version 5 pour que le composant listbingo fonctionne correctement

 

La version 4 de PHP étant la plus utilisée, chez 1&1 Internet l’extension .php est ainsi prise en charge par PHP4.

Si vous souhaitez utiliser PHP5 avec l’extension .php c’est très simple.
Créez alors un fichier qui porte le nom .htaccess et placez le contenu ci-dessous

AddType x-mapp-php5 .php

On peut inclure d’autres extensions qui seront prises en charge par PHP5 en utilisant le même schéma

Script 1: .htaccess
AddType x-mapp-php5 .php .php3 .php4 .htm .html

Une fois votre fichier enregistré, transférez ce dernier sur la racine de votre hébergement web 1&1. 

Facebooktwittergoogle_plusmail

Ajouter Un Commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *